DSpace 6.x Prerequisite Software

system requirements

DSpace 6.x Prerequisite Software


DSpace System Requirements


  • UNIX-like OS or Microsoft Windows

  • Java JDK 7 or 8 (OpenJDK or Oracle JDK)

  • Apache Maven 3.0.5 or above (3.3.9+)* (Java build tool)

  • Configuring a Proxy

  • Apache Ant 1.8 or later (Java build tool)

  • Relational Database: (PostgreSQL or Oracle)

  • PostgreSQL 9.4 or later (with pgcrypto installed)

  • Oracle 10g or later

  • Servlet Engine (Apache Tomcat 7 or later, Jetty, Caucho Resin or equivalent)

  • Git (code version control)